package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http(s)?:\/\/.*(\d{4}).*\/(.*)`)
var str = `http://my-domain-1234.more-stuff.com/snowblower
https://my-domain-1234.more-stuff.com/snowblower
http://example-4321.software.com/xmlsfasfd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}