const regex = /http(s)?:\/\/.*(\d{4}).*\/(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http(s)?:\\\/\\\/.*(\\d{4}).*\\\/(.*)', 'gm')
const str = `http://my-domain-1234.more-stuff.com/snowblower
https://my-domain-1234.more-stuff.com/snowblower
http://example-4321.software.com/xmlsfasfd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}