#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*,(?![^\[\]]*\])"
Local $sString = "6 Wrap" & @CRLF & _
"1 Salad , 2 Pepsi , 2 Chicken Wrap" & @CRLF & _
"1 Kebab Plate [1 Bread ]" & @CRLF & _
"1 Beyti Kebab , 1 Chicken Plate [1 Bread ], 1 Kebab Plate [1 White Rice ], 1 Tikka Plate [1 Bread ]" & @CRLF & _
"1 Kebab Plate [1 Bread , 1 Rocca Leaves ], 1 Mountain Dew "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")