const regex = /\s*,(?![^\[\]]*\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*,(?![^\\[\\]]*\\])', 'gm')
const str = `6 Wrap
1 Salad , 2 Pepsi , 2 Chicken Wrap
1 Kebab Plate [1 Bread ]
1 Beyti Kebab , 1 Chicken Plate [1 Bread ], 1 Kebab Plate [1 White Rice ], 1 Tikka Plate [1 Bread ]
1 Kebab Plate [1 Bread , 1 Rocca Leaves ], 1 Mountain Dew `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}