import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*,(?![^\\[\\]]*\\])";
final String string = "6 Wrap\n"
+ "1 Salad , 2 Pepsi , 2 Chicken Wrap\n"
+ "1 Kebab Plate [1 Bread ]\n"
+ "1 Beyti Kebab , 1 Chicken Plate [1 Bread ], 1 Kebab Plate [1 White Rice ], 1 Tikka Plate [1 Bread ]\n"
+ "1 Kebab Plate [1 Bread , 1 Rocca Leaves ], 1 Mountain Dew ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}