$re = '/\s*,(?![^\[\]]*\])/m';
$str = '6 Wrap
1 Salad , 2 Pepsi , 2 Chicken Wrap
1 Kebab Plate [1 Bread ]
1 Beyti Kebab , 1 Chicken Plate [1 Bread ], 1 Kebab Plate [1 White Rice ], 1 Tikka Plate [1 Bread ]
1 Kebab Plate [1 Bread , 1 Rocca Leaves ], 1 Mountain Dew ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);