using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*,(?![^\[\]]*\])";
string input = @"6 Wrap
1 Salad , 2 Pepsi , 2 Chicken Wrap
1 Kebab Plate [1 Bread ]
1 Beyti Kebab , 1 Chicken Plate [1 Bread ], 1 Kebab Plate [1 White Rice ], 1 Tikka Plate [1 Bread ]
1 Kebab Plate [1 Bread , 1 Rocca Leaves ], 1 Mountain Dew ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}