#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)NAME \d+(?![ \d])"
Local $sString = "NAME 12345A JAMES" & @CRLF & _
"NAME 12345A JAMES" & @CRLF & _
"NAME 12345A JAMES" & @CRLF & _
"NAME 12345A JAMES"
Local $sSubst = "$& "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)