import Foundation
let pattern = #"NAME \d+(?![ \d])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
NAME 12345A JAMES
NAME 12345A JAMES
NAME 12345A JAMES
NAME 12345A JAMES
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$& "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)