const regex = /NAME \d+(?![ \d])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('NAME \\d+(?![ \\d])', 'gm')
const str = `NAME 12345A JAMES
NAME 12345A JAMES
NAME 12345A JAMES
NAME 12345A JAMES`;
const subst = `$& `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);