re = /NAME \d+(?![ \d])/m
str = 'NAME 12345A JAMES
NAME 12345A JAMES
NAME 12345A JAMES
NAME 12345A JAMES'
subst = '$& '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result