use strict;
my $str = 'NAME 12345A JAMES
NAME 12345A JAMES
NAME 12345A JAMES
NAME 12345A JAMES';
my $regex = qr/NAME \d+(?![ \d])/mp;
my $subst = '$& ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";