import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ ]*\\t+[ ]*";
final String string = "\n"
+ "Ulmstead Club\n"
+ "911 Lynch Dr\n"
+ "Arnold, Maryland 21012\n"
+ "United States\n"
+ "(410) 757-9836\n"
+ "Get directions\n"
+ "Favorite court\n"
+ "Tennis Court Details\n"
+ "Location type:\n"
+ "Club\n"
+ "Matches played here:\n"
+ "0\n";
final String subst = "\\t";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}