use strict;
my $str = '
Ulmstead Club
911 Lynch Dr
Arnold, Maryland 21012
United States
(410) 757-9836
Get directions
Favorite court
Tennis Court Details
Location type:
Club
Matches played here:
0
';
my $regex = qr/[ ]*\t+[ ]*/mp;
my $subst = '\\t';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";