const regex = /[ ]*\t+[ ]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ ]*\\t+[ ]*', 'gm')
const str = `
Ulmstead Club
911 Lynch Dr
Arnold, Maryland 21012
United States
(410) 757-9836
Get directions
Favorite court
Tennis Court Details
Location type:
Club
Matches played here:
0
`;
const subst = `\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);