import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?=[^\\}]*want)(?=[^\\}]*bracket)[^\\}]+\\}";
final String string = "{this is a}{string with text}{i want this bracket}{only}\n"
+ "{i want this}\n"
+ "{i this bracket}\n"
+ "{i want this bracket}\n"
+ "{gjddnsgwantjgnsagjbracket}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}