$re = '/{(?=[^}]*want)(?=[^}]*bracket)[^}]+}/m';
$str = '{this is a}{string with text}{i want this bracket}{only}
{i want this}
{i this bracket}
{i want this bracket}
{gjddnsgwantjgnsagjbracket}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);