#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-24-9][0-9]|3[0-35689])[0-9]{13}$"
Local $sString = "331234567890123" & @CRLF & _
"141234567890123" & @CRLF & _
"971234567890123" & @CRLF & _
"" & @CRLF & _
"341234567890123" & @CRLF & _
"371234567890123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")