$re = '/^([0-24-9][0-9]|3[0-35689])[0-9]{13}$/m';
$str = '331234567890123
141234567890123
971234567890123
341234567890123
371234567890123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);