// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-24-9][0-9]|3[0-35689])[0-9]{13}$").unwrap();
let string = "331234567890123
141234567890123
971234567890123
341234567890123
371234567890123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}