using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-24-9][0-9]|3[0-35689])[0-9]{13}$";
string input = @"331234567890123
141234567890123
971234567890123
341234567890123
371234567890123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}