package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-24-9][0-9]|3[0-35689])[0-9]{13}$`)
var str = `331234567890123
141234567890123
971234567890123
341234567890123
371234567890123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}