using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"my_file\d+.txt";
string input = @"my_file1.txt
my_file2.txt
my_file3.txt
my_file4.txt
test.txt
my_file.txt
my_file4123123.txt
my_file4.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}