import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "my_file\\d+.txt";
final String string = "my_file1.txt\n"
+ "my_file2.txt\n"
+ "my_file3.txt\n"
+ "my_file4.txt\n"
+ "test.txt\n"
+ "my_file.txt\n"
+ "my_file4123123.txt\n"
+ "my_file4.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}