// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)my_file\d+.txt").unwrap();
let string = "my_file1.txt
my_file2.txt
my_file3.txt
my_file4.txt
test.txt
my_file.txt
my_file4123123.txt
my_file4.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}