re = /my_file\d+.txt/m
str = 'my_file1.txt
my_file2.txt
my_file3.txt
my_file4.txt
test.txt
my_file.txt
my_file4123123.txt
my_file4.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end