package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)my_file\d+.txt`)
var str = `my_file1.txt
my_file2.txt
my_file3.txt
my_file4.txt
test.txt
my_file.txt
my_file4123123.txt
my_file4.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}