#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bHONOURABLE\s+((?:THE|MR|MS|DR)\b[^,]*)"
Local $sString = "HONOURABLE THE CHIEF JUSTICE MR. JUSTICE" & @CRLF & _
"VIKRAM NATH,HONOURABLE MR. JUSTICE ASHUTOSH" & @CRLF & _
"J. SHASTRI, HONOURABLE MS. ADITI GUPTA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")