re = /\bHONOURABLE\s+((?:THE|MR|MS|DR)\b[^,]*)/m
str = 'HONOURABLE THE CHIEF JUSTICE MR. JUSTICE
VIKRAM NATH,HONOURABLE MR. JUSTICE ASHUTOSH
J. SHASTRI, HONOURABLE MS. ADITI GUPTA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end