use strict;
my $str = 'HONOURABLE THE CHIEF JUSTICE MR. JUSTICE
VIKRAM NATH,HONOURABLE MR. JUSTICE ASHUTOSH
J. SHASTRI, HONOURABLE MS. ADITI GUPTA';
my $regex = qr/\bHONOURABLE\s+((?:THE|MR|MS|DR)\b[^,]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}