package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bHONOURABLE\s+((?:THE|MR|MS|DR)\b[^,]*)`)
var str = `HONOURABLE THE CHIEF JUSTICE MR. JUSTICE
VIKRAM NATH,HONOURABLE MR. JUSTICE ASHUTOSH
J. SHASTRI, HONOURABLE MS. ADITI GUPTA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}