import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bHONOURABLE\\s+((?:THE|MR|MS|DR)\\b[^,]*)";
final String string = "HONOURABLE THE CHIEF JUSTICE MR. JUSTICE\n"
+ "VIKRAM NATH,HONOURABLE MR. JUSTICE ASHUTOSH\n"
+ "J. SHASTRI, HONOURABLE MS. ADITI GUPTA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}