package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<TicketRef>MSG[0-9]{8}\_\w{19}?)`)
var str = `MSG12326339_123euP4l5kb6ZDgFeFJ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}