// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<TicketRef>MSG[0-9]{8}\_\w{19}?)").unwrap();
let string = "MSG12326339_123euP4l5kb6ZDgFeFJ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}