const regex = /(?<TicketRef>MSG[0-9]{8}\_\w{19}?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<TicketRef>MSG[0-9]{8}\\_\\w{19}?)', 'gm')
const str = `MSG12326339_123euP4l5kb6ZDgFeFJ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}