$re = '/(?<TicketRef>MSG[0-9]{8}\_\w{19}?)/m';
$str = 'MSG12326339_123euP4l5kb6ZDgFeFJ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);