re = /(?<TicketRef>MSG[0-9]{8}\_\w{19}?)/m
str = 'MSG12326339_123euP4l5kb6ZDgFeFJ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end