package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mx)^Section
(?:(?!^Section)[\s\S])+?
^Property2:\ Val-d
(?:(?!^Section)[\s\S])+?
(?=^Section|\Z)`)
var str = `Section
-------
Property1: Val-a
Property2: Val-b
Property3: Val-123
Section
-------
Property1: Val-c
Property2: Val-d
Property3: Val-4
Section
-------
Property1: Val-e
Property2: Val-f
Property3: Val-f
Section
-------
Property1: Val-gg
Property2: Val-d
Property3: Val-h
Section
-------
Property1: Val-x
Property2: Val-f
Property3: Val-9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}