use strict;
my $str = 'Section
-------
Property1: Val-a
Property2: Val-b
Property3: Val-123
Section
-------
Property1: Val-c
Property2: Val-d
Property3: Val-4
Section
-------
Property1: Val-e
Property2: Val-f
Property3: Val-f
Section
-------
Property1: Val-gg
Property2: Val-d
Property3: Val-h
Section
-------
Property1: Val-x
Property2: Val-f
Property3: Val-9';
my $regex = qr/^Section
(?:(?!^Section)[\s\S])+?
^Property2:\ Val-d
(?:(?!^Section)[\s\S])+?
(?=^Section|\Z)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}