# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^Section
(?:(?!^Section)[\s\S])+?
^Property2:\ Val-d
(?:(?!^Section)[\s\S])+?
(?=^Section|\Z)
"""
test_str = ("Section\n"
"-------\n"
"Property1: Val-a\n"
"Property2: Val-b\n"
"Property3: Val-123\n\n"
"Section\n"
"-------\n"
"Property1: Val-c\n"
"Property2: Val-d\n"
"Property3: Val-4\n\n"
"Section\n"
"-------\n"
"Property1: Val-e\n"
"Property2: Val-f\n"
"Property3: Val-f\n\n"
"Section\n"
"-------\n"
"Property1: Val-gg\n"
"Property2: Val-d\n"
"Property3: Val-h\n\n"
"Section\n"
"-------\n"
"Property1: Val-x \n"
"Property2: Val-f\n"
"Property3: Val-9")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.