import Foundation
let pattern = #"""
^Section
(?:(?!^Section)[\s\S])+?
^Property2:\ Val-d
(?:(?!^Section)[\s\S])+?
(?=^Section|\Z)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
Section
-------
Property1: Val-a
Property2: Val-b
Property3: Val-123
Section
-------
Property1: Val-c
Property2: Val-d
Property3: Val-4
Section
-------
Property1: Val-e
Property2: Val-f
Property3: Val-f
Section
-------
Property1: Val-gg
Property2: Val-d
Property3: Val-h
Section
-------
Property1: Val-x
Property2: Val-f
Property3: Val-9
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)