// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^Section
(?:(?!^Section)[\s\S])+?
^Property2:\ Val-d
(?:(?!^Section)[\s\S])+?
(?=^Section|\Z)").unwrap();
let string = "Section
-------
Property1: Val-a
Property2: Val-b
Property3: Val-123
Section
-------
Property1: Val-c
Property2: Val-d
Property3: Val-4
Section
-------
Property1: Val-e
Property2: Val-f
Property3: Val-f
Section
-------
Property1: Val-gg
Property2: Val-d
Property3: Val-h
Section
-------
Property1: Val-x
Property2: Val-f
Property3: Val-9";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}