using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\d+)\](:\s)([A-Z]*)";
string input = @"July 31 07:51:48 mycomputer bad_process[12345]: ERROR Performing package upgrade";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}