$re = '/\[(\d+)\](:\s)([A-Z]*)/m';
$str = 'July 31 07:51:48 mycomputer bad_process[12345]: ERROR Performing package upgrade';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);