re = /\[(\d+)\](:\s)([A-Z]*)/m
str = 'July 31 07:51:48 mycomputer bad_process[12345]: ERROR Performing package upgrade'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end