package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(\d+)\](:\s)([A-Z]*)`)
var str = `July 31 07:51:48 mycomputer bad_process[12345]: ERROR Performing package upgrade`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}