using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"N(?:e(?:w(?:\s+(?:Y(?:o(?:r(?:k)?)?)?)?)?)?)?$";
string input = @"How much new sales in new
How much new sales in new yo
How much new sales in new yor";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}