re = /N(?:e(?:w(?:\s+(?:Y(?:o(?:r(?:k)?)?)?)?)?)?)?$/im
str = 'How much new sales in new
How much new sales in new yo
How much new sales in new yor'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end