package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)N(?:e(?:w(?:\s+(?:Y(?:o(?:r(?:k)?)?)?)?)?)?)?$`)
var str = `How much new sales in new
How much new sales in new yo
How much new sales in new yor`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}