const regex = /N(?:e(?:w(?:\s+(?:Y(?:o(?:r(?:k)?)?)?)?)?)?)?$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('N(?:e(?:w(?:\\s+(?:Y(?:o(?:r(?:k)?)?)?)?)?)?)?$', 'igm')
const str = `How much new sales in new
How much new sales in new yo
How much new sales in new yor`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}